Jim Power with Chris Huelsbeck – PA53

Pixelated Audio - Video Game Music podcast and Retro Gaming Chris Huelsbeck Jim Power

Everyone knows that “Amiga love” flows thick in our veins; it’s just a fact. The humble home computer has had so many incredible composers write music for it’s games that many of us in North America are a bit unfamiliar with. Today we bring you the music of Jim Power in Mutant Planet from one of the most prolific western composers in video game history, Chris Huelsbeck. Not only that, he’s also a guest on the show!

Track List:Pixelated Audio - Video Game Music podcast and Retro Gaming Chris Huelsbeck Jim Power
0:00:00 Title Theme (Amiga)
0:12:24 In game 1
0:24:00 In game 5
0:36:04 Mutant’s Forest (SNES)
0:42:22 Flying Shellfish
0:47:31 Stage 2 (PCE CD)
0:57:23 Stage 4
1:01:50 Final Boss
1:17:18 In game 4 (Amiga)
1:26:30 Stage 5 (PCE CD)
1:37:45 Ending/Game Over (Amiga)
1:49:29 Title Theme (PCE CD)


Jim Power in Mutant Planet (Amiga, Amstrad CPC, Atari ST) Jim Power in Mutant Planet (PC Engine CD) + Jim Power: The Lost Dimension in 3D (SNES, DOS)

Composed by Chris Huelsbeck
huelsbeck.com | bandcamp.com | iTunes | Google Play Music | SoundCloud


episode-here2

3 thoughts on “Jim Power with Chris Huelsbeck – PA53

    1. bmosley Post author

      Thanks man, glad you liked it! He’s a very nice guy too. Laid back and still into gaming. Pretty cool :)

      Reply
  1. dr.zeissler

    Hi there, would be nice to know on what setup the original dos-game was trouble-shouted on. The Sound-Detection simply does not work on any of my setups! and I have checked about 10 different machines and about 20 soundcards. Simply none worked.
    Some-Bugs:
    – No Sound at all
    – Sound for about 1-5 seconds
    – Sound until the end of the first demo-level then freezing picture, while sound still plays
    – Sound until the end of the first demo-level then no more sound anymore, second demo starts

    I have checked from 486 up to pentium3 and from the very early soundcards CT1350b,CT1600, CT4170, AWE64, ESS-Solo, Chrystal-Chips, Aztech-Cards, Macintosh PC-Cards 486/Pentium with Vibra16c and so one…so what is the problem here?

    Can we just a a sound-setup that let’s me setup the sound-.settings ? I have spend several hours troubleshooting this game but there is simply no machine or setup that is working fully correct. An early Pentium with AWE64Gold seemed to be OK, but after the first chapter I got a freeze…before that the sound worked OK for me. I have never got any other PC-Dos game that is that hard to get it working…so back to my first question, on what was it coded and trouble-shouted…that MUST be a working version, or was there no trouble-shooting at all?

    Thx
    Doc

    Reply

Leave a Reply to bmosley Cancel reply